Homelab: Dewey

Specs:
– CPU: Intel Core i7-7700k
– Motherboard: Z270 GAMING M3 (MS-7A62)
– GPU: ASUS GeForce GTX960
– RAM: Kingston HyperX 3x8GB DDR4 2.4GHz
– Storage: 2x Corsair MP500 m.2 240G SSDs in mdadm RAID0, 1x WD Black 1TB for storage. 100GB LVM volume as writeback cache for HDD
– Fans: NOCTUA

Roles:
– Docker host
– gaming in virtual machine
– general workstation

Runs:
– ArchLinux

Homelab: node0

Specs:
– 1 x86 64bit Core
– 1.5GB Memory
– 25GB SSD Disk

Roles:
– mysql
– xmpp
– nginx cdn
– Frontend for services in Dockers

Runs:
– Debian testing
– WordPress blog
– Piwik
– Prosody
– TT-RSS

Homelab: TOOR

Specs:
– Intel J1900
– 8 GB of DDR3 non-ecc memory
– 2x WD Blue WD30EZRZ-00Z5HB0 3 TB
– chassis: Fractal Design Node804

Roles:
– Docker host
– backup replication
– backup sync

Runs:
– Debian testing

Docks:

– kanboard/kanboard:stable
– linuxserver/duplicati
– linuxserver/sickbeard
– linuxserver/couchpotato
– guacamole/guacamole
– jenkins
– diameter/rtorrent-rutorrent:latest
– gogs/gogs
– guacamole/guacd
– linuxserver/headphones
– homeassistant/home-assistant

Homelab: wyvern

Specs:
– Intel I3-3220
– 16GB of DDR3 non-ecc memory
– 2x Seagate ST1000DM003-9YN162 1 TB
– Chassis: NZXT Source 210

Roles:
– VM hypervisor
– backup replication

runs:
– Debian testing
– torrents
– virtualized proxmox
– random stuff

Mikrotik 951G na stancji – Orange FTTH

Sprzęt dostarczany przez polskich ISP często pozostawia wiele do życzenia – nie tylko gdy rozważamy jego wydajność, lecz również możliwości konfiguracyjne.

Niezawsze niestety jest możliwość skorzystania z własnego routera. Teoretycznie ja również jej nie miałem. Jednak z odrobiną szczęścia, Google i cierpliwości udało mi się skonfigurować Mikrotika 951G-2HnD do łączenia się z łączem światłowodowym z oferty Orange Supernova

Pierwszym krokiem koniecznym, by cokolwiek zdziałać było w ogóle połączenie się z siecią Orange. Monterzy dostarczyli mi wraz z umową mediakonwerter oraz „FunBoxa”. Samo urządzenie, oferując zaskakująco zaawansowane opcje:

  • harmonogram dostępu do Wifi
  • zmiana serwerów DNS(!!)
  • blokowanie oraz forwarding portów

w zakresie możliwości konfiguracyjnych nie pozostawia szerokiego pola do popisu – funkcje są dostępne, jednak ciężko z nich skorzystać. Podobne rozczarowanie spowodowane jest jego wydajnością – transfery w LANie nie przekraczały 700Mbps, a przy pobieraniu plików z Internetu przez >2 urządzeń klienckich urządzenie wydzielało takie ilości ciepła, że trudno było je długo utrzymać.

Samo logowanie przebiega po PPPoE.

Prędko odkurzyłem więc i uruchomiłem Mikrotika RB951G-2HnD. Do pierwszej konfigurtacji i nawiązania połączenia nieoceniona okazała się wiedza na z dedykowanego wątku na forum Trzepak.pl. Dzięki niemu udało mi się skonfigurować połączenie.


/interface ethernet
set [ find default-name=ether1 ] name=WAN
/interface vlan
add arp=disabled interface=WAN mtu=1492 name=vlan35 vlan-id=35
/interface pppoe-client
add add-default-route=yes disabled=no interface=vlan35 keepalive-timeout=60 max-mru=1492 max-mtu=1492 name=Orange-FTTH password=${PASSWORD use-peer-dns=yes user=${USERNAME}

Natomiast cała reszta konfiguracji to już moja mała inwencja twórcza:

  • osobna podsieć na każdy port ( każdy do innego pokoju/lokatora)
  • osobny vAP
  • bridge między interfejsem kablowym a vAP

Wygląda to tak:
/ip pool
add name=szakalaka ranges=10.2.0.2-10.2.0.254
add name=Rzulty ranges=10.3.0.2-10.3.0.254
add name=Gosc ranges=10.4.0.2-10.4.0.254

/ip dhcp-server
add address-pool=szakalaka authoritative=after-2sec-delay disabled=no interface=wifi-bridge name=szakalaka
add address-pool=Rzulty authoritative=after-2sec-delay disabled=no interface=ether3 name=Rzulty
add address-pool=Gosc authoritative=after-2sec-delay disabled=no interface=ether4 name=Gosc

/interface bridge port
add bridge=wifi-bridge interface=ether2
add bridge=wifi-bridge interface=szakalaka

/ip address
add address=10.2.0.1/24 interface=wifi-bridge network=10.2.0.0
add address=10.3.0.1/24 interface=ether3 network=10.3.0.0
add address=10.4.0.1/24 interface=ether4 network=10.4.0.0