Archiwum kategorii: DIY

Mikrotik 951G na stancji – Orange FTTH

Sprzęt dostarczany przez polskich ISP często pozostawia wiele do życzenia – nie tylko gdy rozważamy jego wydajność, lecz również możliwości konfiguracyjne.

Niezawsze niestety jest możliwość skorzystania z własnego routera. Teoretycznie ja również jej nie miałem. Jednak z odrobiną szczęścia, Google i cierpliwości udało mi się skonfigurować Mikrotika 951G-2HnD do łączenia się z łączem światłowodowym z oferty Orange Supernova

Pierwszym krokiem koniecznym, by cokolwiek zdziałać było w ogóle połączenie się z siecią Orange. Monterzy dostarczyli mi wraz z umową mediakonwerter oraz „FunBoxa”. Samo urządzenie, oferując zaskakująco zaawansowane opcje:

  • harmonogram dostępu do Wifi
  • zmiana serwerów DNS(!!)
  • blokowanie oraz forwarding portów

w zakresie możliwości konfiguracyjnych nie pozostawia szerokiego pola do popisu – funkcje są dostępne, jednak ciężko z nich skorzystać. Podobne rozczarowanie spowodowane jest jego wydajnością – transfery w LANie nie przekraczały 700Mbps, a przy pobieraniu plików z Internetu przez >2 urządzeń klienckich urządzenie wydzielało takie ilości ciepła, że trudno było je długo utrzymać.

Samo logowanie przebiega po PPPoE.

Prędko odkurzyłem więc i uruchomiłem Mikrotika RB951G-2HnD. Do pierwszej konfigurtacji i nawiązania połączenia nieoceniona okazała się wiedza na z dedykowanego wątku na forum Trzepak.pl. Dzięki niemu udało mi się skonfigurować połączenie.


/interface ethernet
set [ find default-name=ether1 ] name=WAN
/interface vlan
add arp=disabled interface=WAN mtu=1492 name=vlan35 vlan-id=35
/interface pppoe-client
add add-default-route=yes disabled=no interface=vlan35 keepalive-timeout=60 max-mru=1492 max-mtu=1492 name=Orange-FTTH password=${PASSWORD use-peer-dns=yes user=${USERNAME}

Natomiast cała reszta konfiguracji to już moja mała inwencja twórcza:

  • osobna podsieć na każdy port ( każdy do innego pokoju/lokatora)
  • osobny vAP
  • bridge między interfejsem kablowym a vAP

Wygląda to tak:
/ip pool
add name=szakalaka ranges=10.2.0.2-10.2.0.254
add name=Rzulty ranges=10.3.0.2-10.3.0.254
add name=Gosc ranges=10.4.0.2-10.4.0.254

/ip dhcp-server
add address-pool=szakalaka authoritative=after-2sec-delay disabled=no interface=wifi-bridge name=szakalaka
add address-pool=Rzulty authoritative=after-2sec-delay disabled=no interface=ether3 name=Rzulty
add address-pool=Gosc authoritative=after-2sec-delay disabled=no interface=ether4 name=Gosc

/interface bridge port
add bridge=wifi-bridge interface=ether2
add bridge=wifi-bridge interface=szakalaka

/ip address
add address=10.2.0.1/24 interface=wifi-bridge network=10.2.0.0
add address=10.3.0.1/24 interface=ether3 network=10.3.0.0
add address=10.4.0.1/24 interface=ether4 network=10.4.0.0

Dell Latitude E6440 loose hinges

Guys, I know the photos got deleted. I don’t have this notebook anymore 🙁 If anyone could take a picture of the screws I described and allowed me to publish them here it would be great.

Dell Latitude E6440 loose hinges problem

may become really annoying to cope with.

Dell Latitude E6440 loose hinges

First thing that comes to mind is tighten the hinges, and it is truely genious! And to make things even better, this is a really easy to do step, but let’s not run ahead of ourselfs.

Czytaj dalej

Życie z technologią – bezpiecznie, wygodnie.

Życie z technologią – bezpiecznie, wygodnie – czy to możliwe?

Technologia jest nieodłącznym elementem codziennego życia niemal każdego człowieka.
Niektórym to życie ułatwia, niektórym utrudnia. Są osoby, które nie umieją z niej korzystać, żyją w fałszywym przeświadczeniu że umieją, a całej reszczie pomaga z dnia na dzień.
Pomyślałem, że opis tego w jaki sposób sam korzystam z technologii na co dzień może być źródłem inspiracaji dla innych, jak i wszelkie komentarze cennymi uwagami dla mnie.

Czytaj dalej

DNScrypt – szyfrowanie zapytań DNS

DNScrypt – szyfrowanie zapytań dns

Rola serwerów i żądań DNS przez wiele osób traktowana jest z pewną dozą ignorancji. Podejście “jest? działa? to jest dobrze” okazuje się nie zawsze być poprawne.
O co chodzi? Właśnie o te nieszczęsne zapytania DNS!
Zabawa z DNSami umożliwia nie tylko rejestrowanie odwiedzanych przez użytkownika stron (np. przez ISP, organizacje rządowe, złośliwe rodzeństwo/administrator) lecz również nieco
bardziej niebezpieczne rzeczy. Jak więc się przed tym ustrzec?

Czytaj dalej

Ograniczenia i limity nie interesują mnie, czyli życie na publicznej sieci.

Często i gęsto zdarza się, że sieci na uczelniach, w hotelach bądź restauracjach mają nałożone poważne restrykcje.
Możliwe, że kiedyś ktoś narozrabiał, i w wyniku tego konieczne było ograniczenie możliwości.
Jednak co w sytuacji, w której szerszy dostęp do internetu potrzebny jest w dobrych celach?
Sytuacja życiowa inspirująca napisanie tego artykułu: sieć na uczelni, która dopuszcza ruch z siecią Internet tylko i wyłącznie na portach 80 oraz 443 TCP.

Czytaj dalej

Mail-in-a-box – serwer mailowy w jednym skrypcie, w kontenerze lxc

Jak łatwo i szybko postawić dobry serwer mailowy, z niemal wszystkimi możliwymi wodotryskami?
Wydawać by się mogło, że to nie możliwe, a z pewnością wymagałoby dużo pracy… jakby więc podjąć temat tak, żeby sie nie narobić..?
Z pomocą przyszedł mi całkiem niezły skrypt, mail-in-a-box!

Czytaj dalej

ArchLinux mirror

ArchLinux mirror

archlinux mirror

Thanks to Let’s Encrypt I’ve deployed tls-enabled ArchLinux mirror server. It is available at:

http://mirror.tyborek.pl/arch/
https://mirror.tyborek.pl/arch/

It is already added to official mirrorlist, if suitable you will use it automagically.

Qualys SSL Labs has graded this mirror as A+, improving overall security. SSL configuration is following guidelines pointed out at cipherli.st.

I think it is a good place to mention reflector, a really good tool to generate list of the best available mirrors. Speeds up pacman significantly.

Up to date ArchLinux mirror rank can be found here